MitsuStyle MitsuStyle

Go Back   MitsuStyle > The Homefront! > The Parking Lot - On & Off Topic > Video Forum

Reply
 
Thread Tools Display Modes
Old 07-06-2018   #1
CarPsyco84
 
CarPsyco84's Avatar
 

Join Date: Jan 2005
Location: Coon Rapids
Drives: 91' talon, 16' Beta 300RR
Posts: 799
Last run from today.

Last run from today, launched with low boost, tried to flip the switch into second but didn't get it till 3rd. Was still a 7.24 @ 105 to the 1/8th. Clutch disc failed on the shift for 4th.

https://drive.google.com/file/d/1Vtj...w?usp=drivesdk
__________________
-When in doubt, Moar RPM.
CarPsyco84 is offline   Reply With Quote
Old 07-07-2018   #2
93gtpeater
 

Join Date: Apr 2008
Location: stillwater
Drives: cbr 1000rr repsol
Posts: 1,450
Re: Last run from today.

Wow almost in the 6s. What you think that thing makes for power?
93gtpeater is offline   Reply With Quote
Old 07-08-2018   #3
CarPsyco84
 
CarPsyco84's Avatar
 

Join Date: Jan 2005
Location: Coon Rapids
Drives: 91' talon, 16' Beta 300RR
Posts: 799
Re: Last run from today.

Quote:
Originally Posted by 93gtpeater View Post
Wow almost in the 6s. What you think that thing makes for power?
ECMlink says around 580whp, 1/4 Mile calc says 620-630whp depending on how and which one you use. 1st and second on this run were barely even 400whp (low boost). Didn't even feel like it moved till 3rd gear.
__________________
-When in doubt, Moar RPM.
CarPsyco84 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:44 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.